Общие
Личный кабинет
Оборудование
Ошибки и способы их устранения

CAPsMAN с двумя SSID — гостевая и рабочая сеть

CAPsMAN с двумя SSID — гостевая и рабочая сеть

ОБРАЩАЕМ ВНИМАНИЕ!

Данная инструкция подходит для настройкиMikrotikOS v6.40

Работать на других версиях может не корректно.

Настройка CAPsMAN на микротике с двумя сетями: рабочей и гостевой

В первую очередь необходимо настроить два бриджа на микротике с гостевой и рабочей сетью.

За основу берется инструкция по настройке хотспота на микротике.

Чтобы в дальнейшем не испытывать затруднений мы рекомендуем заменить следующие строки:

/ip pool add name=inet-pool ranges=192.168.100.2-192.168.103.253

/ip dhcp-server add address-pool=inet-pool disabled=no interface=ether2 lease-time=16h name=inet-dhcp

/ip address add address=192.168.100.1/22 comment="Internet network" interface=ether2 network=192.168.100.0

/ip dhcp-server network add address=192.168.100.0/22 comment="Internet network" dns-server=8.8.8.8,208.67.222.222 gateway=192.168.100.1 netmask=22

/ip firewall nat add action=masquerade chain=srcnat comment="masquerade Internet network" src-address=192.168.100.0/22

на:

/interface bridge add name=hs-bridge

/ip dns set allow-remote-requests=yes servers=8.8.8.8,208.67.222.222

/ip dhcp-client add dhcp-options=hostname,clientid disabled=no interface=hs-bridge

/interface wireless cap set discovery-interfaces=hs-bridge enabled=yes interfaces=wlan1

/interface bridge port add bridge=hs-bridge interface=ether3

/interface bridge port add bridge=hs-bridge interface=ether4

/interface bridge port add bridge=hs-bridge interface=ether5

/interface bridge port add bridge=hs-bridge interface=ether2

/interface bridge port add bridge=hs-bridge interface=ether1

Это необходимо для того, чтобы рабочая сеть была настроена на отдельный inet-bridge, а не просто на отдельный порт в микротике.

По окончании настройки вы должны получить отдельный хотспот с гостевой и рабочей сетью в разных бриджах (hs-bridge и inet-bridge).

приступим к настройкам CAPsMAN.

Сжатая инструкция

Сначала меняем пароль рабочей сети с 12345678 на Ваш пароль. Затем в терминал основного микротика вставляем следующий конфиг:

/interface bridge add name=bridgeCAP

/caps-man manager set enabled=yes

/caps-man channel add band=2ghz-b/g/n frequency=2457 name=hs-channel1 tx-power=20 control-channel-width=20

/caps-man datapath add bridge=hs-bridge name=hs-datapath1 client-to-client-forwarding=yes

/caps-man datapath add bridge=inet-bridge name=inet-datapath1 client-to-client-forwarding=yes

/caps-man security add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name="inet-security" passphrase=12345678

/caps-man configuration add channel=hs-channel1 datapath=hs-datapath1 mode=ap name=hs-cfg1 rx-chains=0,1,2 tx-chains=0,1,2 ssid=CAPs-free

/caps-man configuration add channel=hs-channel1 datapath=inet-datapath1 mode=ap name=inet-cfg1 rx-chains=0,1,2 tx-chains=0,1,2 ssid=CAPs-work security=inet-security

/caps-man provisioning add action=create-dynamic-enabled master-configuration=inet-cfg1 slave-configuration=hs-cfg1

/interface wireless cap set enabled=yes interfaces=wlan1 discovery-interface=bridgeCAP bridge=none

Следующий конфиг вставляем в дополнительные роутеры и точки:

/interface bridge add name=hs-bridge

/ip dns set allow-remote-requests=yes servers=8.8.8.8,208.67.222.222

/ip dhcp-client add dhcp-options=hostname,clientid disabled=no interface=hs-bridge

/interface wireless cap set discovery-interfaces=hs-bridge enabled=yes interfaces=wlan1

/interface bridge port add bridge=hs-bridge interface=ether3

/interface bridge port add bridge=hs-bridge interface=ether4

/interface bridge port add bridge=hs-bridge interface=ether5

/interface bridge port add bridge=hs-bridge interface=ether2

/interface bridge port add bridge=hs-bridge interface=ether1

Развернутая инструкция

Для ручной настройки по каждому пункту необходимо воспользоваться нижеприведенной инструкцией.

Настройка главного микротика:

Создадим новый бридж bridgeCAP в меню Bridge

name=bridgeCAP

1) Заходим в CAPsMan.

В меню нажимаем CAPsMan-CAP Interface-Manager

Напротив enabled=yes ставим галочку и нажимаем ОК

2) Делаем настройки во вкладке channel.

band=2ghz-b/g/n

frequency=2457

name=hs-channel1

tx-power=20

control-channel-width=20

3) Во вкладке datapath пропишем для hs-bridge.

bridge=hs-bridge

name=hs-datapath1

client-to-client-forwarding=yes

4) Добавим datapath для inet-bridge.

bridge=inet-bridge

name=inet-datapath1

client-to-client-forwarding=yes

5) Для рабочей сети добавляем security профиль.

authentication-types=wpa2-psk

encryption=aes-ccm

group-encryption=aes-ccm

name=inet-security

passphrase=12345678

6)Для гостевой сети добавляем конфигурацию.

channel=hs-channel1

datapath=hs-datapath1

mode=ap

name=hs-cfg1

rx-chains=0,1,2

tx-chains=0,1,2

ssid=CAPs-free

7) Для рабочей сети добавляем конфигурацию.

channel=hs-channel1

datapath=inet-datapath1

mode=ap

name=inet-cfg1

rx-chains=0,1,2

tx-chains=0,1,2

ssid=CAPs-work

security=inet-security

8) Открываем вкладку provisioning и производим настройки.

action=create-dynamic-enabled

master-configuration=inet-cfg1

slave-configuration=hs-cfg1

9) На Wlan интерфейсах включаем CAPsMAN.

enabled=yes

interfaces=wlan1

discovery-interface=bridgeCAP

bridge=none

Теперь настроим роутеры и дополнительные точки

1) Создадим бридж.

name=hs-bridge

2) В него добавляем все Lan интерфейсы.

3) Далее на очереди настройка DHCP Client.

dhcp-options=hostname,clientid

disabled=no

interface=hs-bridge

4) Настройка DNS.

allow-remote-requests=yes

servers=8.8.8.8,208.67.222.222

5) Запустим CAPsMAN.

discovery-interfaces=hs-bridge

enabled=yes

interfaces=wlan1

Поздравляем! Вы завершили настройку, можно приступать к работе!

|Сайт|О компании|Контакты|